Thursday, February 23, 2012
LAB 1 mpls backbone sham link config
mpls ldp router-id lo0
ip vrf vpnA
rd 100:1
route-target export 100:1
route-target import 100:1
!
interface Loopback1
ip vrf forwarding vpnA
ip address 7.7.100.5 255.255.255.255
!
interface FastEthernet0/0
mpls label protocol ldp
tag-switching ip
!
interface FastEthernet0/1
ip vrf forwarding vpnA
ip address 7.7.0.130 255.255.255.224
!
router ospf 1 vrf vpnA
router-id 7.7.5.5
area 0 sham-link 7.7.100.5 7.7.100.4
area 51 virtual-link 7.7.7.7
redistribute bgp 100 subnets
network 7.7.0.130 0.0.0.0 area 51
!
router bgp 100
no bgp default ipv4-unicast
neighbor 7.7.4.4 remote-as 100
neighbor 7.7.4.4 update-source Loopback0
!
address-family vpnv4
neighbor 7.7.4.4 activate
exit-address-family
!
address-family ipv4 vrf vpnA
redistribute ospf 1 match internal external 1 external 2
network 7.7.100.5 mask 255.255.255.255
exit-address-family
R5#s ip bgp vpnv4 all sum | b Nei
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
7.7.4.4 4 100 21 31 190 0 0 00:11:49 20
R5#s ip ospf ne
Neighbor ID Pri State Dead Time Address Interface
7.7.4.4 0 FULL/ - - 7.7.100.4 OSPF_SL3
7.7.7.7 0 FULL/ - - 7.7.0.129 OSPF_VL2
7.7.7.7 1 FULL/DR 00:00:37 7.7.0.129 FastEthernet0/1
tclsh
foreach address {
7.7.1.1
7.7.2.2
7.7.3.3
7.7.7.7
7.7.8.8
7.7.9.9
7.7.10.10
} {ping vrf vpnA $address rep 3}
Subscribe to:
Post Comments (Atom)
No comments:
Post a Comment